HELP! Today everything stopped working.



  • I have been using my wemos d1 mini pro in Arduino for close to 6 months.
    I have been coding and flashing without issues.

    I upgraded to 2.3.0 rc2 board manager and now nothing will work with wemos.
    I immediately rolled back to 2.3.0 rc1. Same result you see below.
    Rolled back again to 2.1.0 rc2 Same results you see below.

    I uninstalled Arduino...reinstalled.
    Booted...I tried everything I could.

    Actually some compile attempts using other boards worked. I didn't try flashing due to processor wasn't correct.

    Plugging in and unplugging the board via USB device manager sees the board. The board appears and goes away in the device manager as you plug it in and unplug it.

    I am hoping someone can provide a clue to get me going again.
    I tried all speed settings etc. Nothing changed that the board isn't found now.
    I tried multiple boards.

    Output from Arduino IDE...

    Arduino: 1.8.2 (Windows 10), Board: "WeMos D1 R2 & mini, 80 MHz, 921600, 4M (3M SPIFFS)"

    C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\gbale\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\gbale\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\gbale\OneDrive\Documents\Arduino\libraries -fqbn=esp8266:esp8266:d1_mini:CpuFrequency=80,UploadSpeed=921600,FlashSize=4M3M -ide-version=10802 -build-path C:\Users\gbale\AppData\Local\Temp\arduino_build_377222 -warnings=none -build-cache C:\Users\gbale\AppData\Local\Temp\arduino_cache_664803 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.esptool.path=C:\Users\gbale\AppData\Local\Arduino15\packages\esp8266\tools\esptool\0.4.8 -prefs=runtime.tools.xtensa-lx106-elf-gcc.path=C:\Users\gbale\AppData\Local\Arduino15\packages\esp8266\tools\xtensa-lx106-elf-gcc\1.20.0-26-gb404fb9-2 -prefs=runtime.tools.mkspiffs.path=C:\Users\gbale\AppData\Local\Arduino15\packages\esp8266\tools\mkspiffs\0.1.2 -verbose C:\Users\gbale\OneDrive\Documents\Arduino\HC UltraSonic\sketch_mar15a\sketch_mar15a.ino

    Board d1_mini (platform esp8266, package esp8266) is unknown

    Error compiling for board WeMos D1 R2 & mini.

    HELP!




Log in to reply
 

Looks like your connection to WEMOS Forum was lost, please wait while we try to reconnect.