Wemos D1 Mini and Wemos Motor Shield issues



  • Hi there,

    I've got a Wemos D1 Mini and the Wemos Motor Shield, but the example programs shipped don't make anything happen.

    I'm just using Motor 1 right now, with 3v powering the D1 and 12v going into the Motor Shield via Vm and Ground on the motor shield. I've tried all the example programs, but no movement on the motors at all.

    I then tried the Wemos I2C scanner - but that doesn't find any I2C devices.

    What could be the problem?



  • The motor shield is a pretty nice piece of hardware, but the firmware they wrote for it is super bad. On any error it will just crash, hang and pull down both i2c lines, making it impossible to communicate with it. The errors include sending it anything it didn't expect, running a bus scan, not sending it anything for some time and just random crap outs.

    The firmware source code is now published, but so far nobody actually fixed it. I made a small attempt at it myself, but didn't go very far.



  • Thanks for the information - but where is the code published? And is there a tutorial on how to flash the firmware for the shield?

    many thanks



  • There is no tutorial. I started a project to figure it all out (documented at https://hackaday.io/project/18439-motor-shield-reprogramming) but I didn't do much progress yet -- busy with real life stuff and other projects.


Log in to reply
 

Looks like your connection to WEMOS Forum was lost, please wait while we try to reconnect.