D1 Mini no UART input



  • I want to make a udp-uart bridge using the firmware from https://gitlab.com/festlv/esp-mavlink-bridge/tree/master

    After long hours of work I got the software working but now I'm stuck with the same problem I had with different firmwares.
    Previously I tried mavesp8266 (https://github.com/dogmaphobic/mavesp8266) with no success, same no UART in issue.
    I also wanted to write my own software using a library called esp universal io (https://github.com/eriksl/esp8266-universal-io-bridge) but that software didn't recognize any input from serial too.

    I'm trying to communicate with ArduPilot Mega 2.8 board, which uses 57600 baudrate and sends MavLink messages (binary)
    The telemetry port in that board is using 5V so I have been using a simple voltage divider with three 1K resistors with these layout:

    APM Telemetry TX -------- 1K ----|------ D1 Mini RX
    |
    |1K____1K Ground

    I also have a usb uart (ch340, 5V-3V3) and tried this setup by connecting voltage divider circuit to usb-uart rx and usb-uart tx to apm rx and grounds to each other, it worked. I'm not really sure if this guarentees that it's gonna work on 3V3 board.

    I can connect to the device via udp using the esp-mavlink-bridge firmware and send commands. I can see the udp received and serial sent counter values incrementing as I press enter or type etc. but Serial received is always zero. (sometimes 2)

    Can somebody help me? I directly connected the 5V apm Tx to D1 Rx since I gave up from the board but nope still nothing, is it the voltage level problem? What would be the problem be?


Log in to reply
 

Looks like your connection to WEMOS Forum was lost, please wait while we try to reconnect.